理想のiOSアプリを求める

全くのプログラミング初心者の私がiOSアプリ開発でつまづいたところなどを中心に記事にして行きます。

cocoapods

【Swift エラー】'GoogleUtilities/GULURLSessionDataResponse.h' file not foundの回避方法一例

プロジェクトに入っているFirebase Admob関連のライブラリが原因です プロジェクトに入っているFirebase Adomb関連のPodを全て一回削除します。 削除するには Podfileの文をコメントアウトするだけです。 #pod 'Firebase/Analytics' #pod 'Firebase/Crashlyt…

Chameleon FrameWorkがswift5で使えない時

github.com こちらを参考にさせていただきましたが、 pod 'ChameleonFramework/Swift', :git => 'https://github.com/wowansm/Chameleon', :branch => 'swift5' でpod installしてください。

CocoaPods をアップデートする

qiita.com こちらの記事を参考にさせていただきました。 記事では[sudo]となっているのですが、古い書き方なのか この書き方だとうまくいきません。 [ ]を取って ターミナルに sudo gem update cocoapods と入力してください cocoapodsがアップデートされま…

realmSwift pod installできないバージョン4.4.1

新しくMacを買い替えたのですが xcodeのプロジェクトを移してpod installしたところ firebaseだとか他のやつはpod installに成功するのに realmSwift だけは ### Error ``` JSON::ParserError - 767: unexpected token at '' /System/Library/Frameworks/Rub…

Mac cocoa podsのバージョンとか確認する方法

ターミナルで pod env と入力しましょう ### Stack ``` CocoaPods : 1.9.1 Ruby : ruby 2.6.3p62 (2019-04-16 revision 67580) [universal.x86_64-darwin19] RubyGems : 3.0.3 Host : Mac OS X 10.15.4 (19E266) Xcode : 11.4.1 (11E503a) Git : git version…

iOS13のiPadの横画面でAdmobのインタースティシャルがうまくいかない場合

iOS13のiPadの横画面でAdmobのインターティシャルがポップアップウインドウみたいになってしまってうまく閉じられなかったりする FirebaseとGoogle-Mobile-Ads-SDK をアップデートしましょう ターミナルに移動して 自分のアプリのディレクトリにcdで移動して…

【swift アプリ開発】アプリアップデートする時は最初にpod updateしたほうがいい:CropViewControllerがブラックアウトする

SwiftのライブラリCropViewControllerをcocoapodsで入れて使っていたんですが。 久しぶりに起動してみたら(iOS13.3) 写真をトリミングして完了を押したときに、画面がブラックアウトするようになってしまいました。 前まで使っていた CropViewController 2…

(linker command failed with exit code 1 (use -v to see invocation)) やCould not build Objective-C module 'Firebase' やFirebaseCore.h' file not foundのエラー回避の一例

Firebaseをcocoapodsなどでインポートすると (linker command failed with exit code 1 (use -v to see invocation)) , Could not build Objective-C module 'Firebase' , FirebaseCore.h' file not found こんなエラーが出てくる 人により症状が違うので こ…

`[FIRApp configure];` (`FirebaseApp.configure()` in Swift) could not find a valid GoogleService-Info.plist in your project

admobを使おうとしたらこのエラーが出ました admobやFirebaseを使うには GoogleService-Info をダウンロードしてプロジェクトに追加しなくてはなりません。 それで私はFirebaseのSDK setupにそって確実に進めたつもりでしたがエラーが出ました `[FIRApp conf…